Noob in need of help with build


#21

404 means that the location you entered cannot be found.

In the Android App in the Kegbot URL did you enter the URL of your Kegbot Server? It sounds like you’re running on a different port number so the format of the Kegbot URL would be http://192.168.1.1:3000 or http://mykegboturl:3000. Replace the IP Address or mykegboturl and port number with your actual IP address and port number of the Kegbot Server running on your Raspberry Pi.

It sounds like you may have already gotten past that part if you’re making it to the Link This Device page in the App. Once there, visit the website for your Kegbot Server and just add ‘/link’ to the end of the url (eg. http://192.168.1.1:3000/link). This should give you the opportunity to enter the code displayed on your android tablet and once complete the tablet should automatically cycle to the next screen and will be fully linked.


#22

@johnnyruz Thanks. Yes, on the tablet app, it prompts me for the name ip address of my server I entered it initially as http://192.168.1.1:3000 it recognizes it and immediately moves to the link screen with a code to enter (I tried entering the wrong address too, just to make sure it prompts you if it doesn’t “see” the server, and it does). Through the app, I click the hyper-link that says http://192.168.1.1:3000/link and that’s when I get the 404 error. I then tried to do it outside the app directly on my windows computer and I get the same 404 error. Then I went to the tab where I actually had the webversion of the kegberry server pulled up and just added link to the end of the address (this was my no-ip address) http://noipaddress:3000/link. Same 404 address. I then went back into the app and tried the noipaddress:3000 instead of the ip address. The app also recognizes that, prompts with a new code…but when going to the browser and entering the info, I still get a 404 message.

I then figured maybe it was something wacky with the port number I was using and decided to change it just to be sure that wasn’t an issue. I tried sudo nano /home/kegbot/.kegbot/local_settings.py and I can’t remember the exact error, but it’s basically telling me it can’t find it and tries to create a new file with that name. I tried both in putty and on the pi directly. Could this be my issue? Any idea what may have happened? Sorry John…I really thought I was on the downhill side of things at this point.


#23

Ok, a bit more info…I noticed that when I enter http://noipaddress:3000/link it opens http://noipaddress/kegadmin/devices/link/ if I edit that and add the port back in (ie. http://noipaddress:3000/kegadmin/devices/link then the prompt comes up for me to enter the code. Now I have the tablet linked. I’m still a little concerned that I can’t seem to get into my local_settings.py file. Any suggestions what may be going on there?