Rfid conection to arduino nano

Does anyone have the conection for an RFID RC522 to Arduino Nano V3?

I’ll put together a drawing at some point soon for the Uno, Nano v3, and Mega, but the v3 should be the same as the Uno assuming you’ve flashed my firmware from Github.


3.3V <–> 3.3V
RST <–> D10
IRQ <–> D6
MISO <–> D12
MOSI <–> D11
SCK <–> D13
SDA <–> D9

Pin out worked great thank you

when I scan an RFID tag for the first time it says access denied assign to user or cancel. I go to the server and put in user name and nice name when I hit save , username clears and only nice name is left save does nothing at that point. Am I inputting in the wrong order?

No you’re good, it seems like a bug on the initial save. If you leave that screen and come back you should see both fields successfully populated.

Thank you
Yes it does work 2nd time around
Thanks again for the info

Do you, by chance, have a picture of the connections for the mega, or a pinout. I have been trying to get it to work for a couple days now. Obviously I’m missing something. Thanks!!!


3.3V <–> 3.3V
RST <–> D10
IRQ <–> D6
MISO <–> D50
MOSI <–> D51
SCK <–> D52
SDA <–> D9

I have some of the cheap Amazon RC522 readers, but I also have a Velleman VMA405 reader as well. The VMA405 does not use the IRQ Pin so it’s not connected to anything. I’ll have to test the RC522 without IRQ connected to see if it still works, but this pinout should work for any similar RFID readers connected to an Arduino Mega.

Hmmm…i’ve tried that pinout, without success. I get no response from the reader. I wonder if it is dead. I’ve read a couple of your other posts about using kegboard-monitor.py to view status, but it never says anything about rfid. Is there any other way to test the rfid-rc522?

BTW…thank you! Your information and posts are great!!!

I’ve done some other testing with the reader, both on a NodeMCU and my current Mega, using other arduino code…and both work and return the two cards that were included with the reader. Now…just to figure out why the mega <-> RFID-RC522 aren’t playing well together with the kegboard sketch.

From above, it seems that the pinouts are exactly the same for mega and nano, with three exceptions (MISO, MOSI and SCK). Is that right? And the standard code, out of the box, should be setup to work, correct? When connected in Arduino IDE I do get the following:

KBSP v1: 0 {gibberish}

None of that changes when I scan or hold a card over the reader.

Nevermind…I am an idiot. Somehow I got old code and the RC522 info wasn’t even in there. On one of your other posts it took me to the code and i saw it was in there, so I downloaded and updated…now I get:

KBSP v1: core.rfid {gibberish}