Android Tablet Always Logs Pours as Guest


#1

Moving this out to a new topic so it doesn’t get lost in the New Installation topic.

@Necro wrote:

Thanks Johnnyruz… Used a samsung Tablet… the 3 little dots dont come up for some reason…I could see it with the kegbot app on the Phone.
Having endless problems tho on server side… think I will format and give it one more try… Pours register fine… but always register pours as Guest… even when I select another User.

Fresh Jessie install, but still not able to link pours to drinkers… all the pours register as guest… Not sure what to do… could it be the android device I’m using ?
Pours register, but if i try and do calibration it does not detect flow, so can’t calibrate. Is there a file I can tinker with to do it manually? this is the meter Im using https://docs-emea.rs-online.com/webdocs/1636/0900766b816369c1.pdf. so 1420/L.


#2

Hi @Necro,

I tested the other night with my Acer tablet and wasn’t able to replicate the same behavior, but maybe I was doing something different.

  1. From the home screen, I start a pour
  2. The Pour in Progress screen starts and the counter starts going and a picture is taken
  3. After I stop pouring, I tap “Claim This Pour”
  4. Taken to a menu where I can select a user
  5. After I select a user, I’m taken back to the Pour in Progress screen and the pour volume counts up, but stops at the value where I initially stopped the pour.
  6. I then tap “Done Pouring”. After I do that, I’m taken back to the main screen where in about 10 seconds I see the last activity pop up in the list and I can confirm on the server web UI that the pour was logged to the correct user.

Following this method, is this not happening with your Samsung tablet?


#3

Hi, thanks for the effort.
I can see that it registered the pours, but only when looking at the stats… it shows volumes of last pours. But when I select a user and start the pour it stays on zero and does not count the pour (not on that screen anyway… same as when I try to calibrate) I did (another) fresh install and get the following error. …it finishes the install and server seems to work except for my mentioned issues…could this be the problem ? See it was mentioned on some chat somewhere… for some it helped to use LAN and not wifi when downloading and installing for some reason… I tried but received the same errors.


#4

I’m not sure that’s causing the issue with your Android not logging users correctly, but any installation failures can’t be good!

That HTTP Error 403 is a known issue with the current installation methods since the online repository has made HTTPS mandatory and the legacy Kegbot packages are still trying to connect via HTTP.

If you start fresh and perform the installation using my method in the “New Installation” thread, you’ll see the section where you download a package that I put together on Google Drive. This contains the required Kegbot Server packages that you can install locally rather than trying to connect to online repositories.

For your Flow Meter Arduino controller, is that connected directly to your tablet or connected to the Raspberry Pi?


#5

Thanks…install went well…Flow meters connected to ArduinoUno board and using Raspberry for the server…SO Arduino connected to raspberry and not directly to tablet.
Pours only register on the raspberry,and then reflects on the Tablet one updated…the actual real time pours dont show on tablet… Is that maybe the reason why all pours link to guest account, since it doest register a pour to a user…and app thinks a pour was not made. ? Hope this all makes sense.
Regards


#6

@Necro,

That’s exactly the issue. The “live pour” and calibration only work when the tablet is being used to interface with the Arduino and flow meters.

There are two ways to setup Kegbot/Kegberry. If you connect the Arduino to the tablet, the Kegbot Android App registers the pour, takes a picture (if enabled), allows you to write a message, and also allows you to assign the pour to a user. Once all of that is complete and you choose “Done Pouring”, the tablet sends all of that information to the Kegbot server (raspberry pi) to be permanently stored.

The second option is the way you have it where the Raspberry Pi interfaces with the Arduino and flow meters. Unfortunately in this configuration you lose the ability to see the live counter updates, calibrate meters, and assign pours to users at the time of the pour.

In short, there’s no “live” updates sent from the server to the Tablet. Every pour recorded is defaulted to “Guest” which you can change after the fact through the web interface. The pours are recorded directly on the server which the tablet app eventually picks up by requesting data from the web server on a set schedule.


#7

Thanks for the help,…seems all sorted, have so pours triggering when I switch anything on in the house like like switch…but still have wires everywhere… will shorten cables and clean up and see if it helps…
I tried getting the twitter working, any idea what the call back url must be ? Im getting a
"Error: Invalid status code 401 while obtaining request token from https://api.twitter.com/oauth/request_token" Ive tried “http://kegbot.example.com/sr/twitter/callback/” and some other suggestions I’ve found on forums, but nog getting it to link my twitter account.


#8

My callback URL on the Twitter App configuration looks like: http://[public URL for my kegbot]/kegadmin/plugin/twitter/


#9

Thanks. but im clueless with this… where or how will i find public url for my kegbot ?


#10

In order to integrate with Twitter, your Kegbot Server needs to be accessible on the public internet.

If you have a standard home network configuration where your ISP provides a single dynamic IP address, you will need to configure your Wifi/Wired router to forward incoming request to your public IP address on port 80 to the IP address of your Kegbot Server.

Once you’ve configured port-forwarding correctly, you should be able to connect to your Kegbot Server from anywhere by opening a web browser and navigating to the public IP Address assigned to you by your ISP. You can easily find this by visiting https://www.whatismyip.com/.

Once you’ve confirmed that is working, you can then use a service like NOIP.com to create a free hostname that maps to your IP address, rather than having to remember the IP address yourself.

If you run into issues, just google how to setup port forwarding to a server inside your network.

After all that is completed and you can access kegbot from the web, the twitter callback URL will be http://[PUBLIC URL]/kegadmin/plugin/twitter/. Where the PUBLIC URL is your public IP address or the name you setup with NOIP.


Twitter plugin error
#11

Thanks Jonny… DId the port forwarding… and no-ip… still not winning if I type the no-ip address instead of the kegbot server ip in my internal network I can now see kegbot site, but not if im trying from outside my home network… It is port 80 I’m suppose to be using? (tried 8000 and 8080 as well) saw few ppl mentioning that my ISP might block 80 that and there is a kegbot-server.conf file one can change the port… any idea where i can find this file…?
Thanks in advance


#12

To change the port that Kegbot runs on, you will need to update the NGINX config file at /etc/nginx/sites-available/default. Change the “listen 80;” line to “listen XXXX;” for whatever port you wish to run the server on. Then either restart the server or reboot your Pi.

The local configuration file for kegbot is located by default at /home/kegbot/.kegbot/local_settings.py but this does not control the web-server, just some parameters used by Kegbot Server like the e-mail configuration settings, DEBUG flag etc.


#13

Thanks… manage to sort out getting server on the net…ISP blocked port 80 by default.
Images dont seem to display when looking at server from internet, but that’s not big issue for me, I would just like to get the the twitter working, stil getting the call_back error. currently using http://xxxx.ddns.net/kegadmin/plugin/twitter/.

I see now my no-ip does not have the http:// in front of address, but twitter does not recognize it as proper call back url if it doesnt start with the http://… maybe thats my problem.


#14

Make sure that in your local_settings.py file you have the KEGBOT_BASE_URL parameter set to the path of your kegbot server, that should solve your image display problem. (i.e. KEGBOT_BASE_URL = ‘http://xxx.ddns.net/’)

I would add the HTTP to the front of your twitter callback URL and make sure you have your consumer key and consumer secret populated. Make sure you can navigate to the URL provided to twitter via a web browser as well.