Arduino Mega CH340 not connecting to android


Hey guys, building a 3 tap Kegbot on an Arduino Mega 2560.
I’ve successfully flashed the kegbot firmware from here:
using these instructions:

Everything seems to go OK, but when jumping pin 12 to the sensor pins (2,3,20,21) I only get a flash appearing on the Rx, not the Tx. Which I understand means that the arduino is receiving data but not transmitting.
Same result when hooking up one of the flow meters.

When I connect the arduino to my tablet - Kegbot app does not seem to recognize the flow meter. When trying to allocate a flow meter to a tap, the only option I have is kegboard.flow.0, which does not recognise any ‘pours’ (tested by blowing through the flow meter).

Have I got a dud board?

Update -

I’ve plugged my arduino into my PC and used the arduino serial monitor. This seems to be working - I’m getting a string of characters when i blow through the flow meter.

Connected to my tablet - nothing. Same as before. I think maybe because it is a clone arduino running the CH340 chip. I had to install a driver on my PC when trying to use it.

When I connect to the tablet using a serial monitor app I get “no serial device”

I tried the app “DroidTerm” as it specifically mentioned support for CH340

USB Virtual Serial Port

When blowing through the flow meter again I get a stream of characters.

Kegbot still does not see the flow meter

Anyone have any ideas how you get the app/android to recognise the CH340 arduino?

FYI - this has been solved -