Arduino Mega not recognised as a controller by App


#1

I recently successfully built as system using a rooted Nexus 7, Raspberry Pi server, cheap flow meters, temp sensor and an Arduino Duemilanove. All worked very well for my 2 tap fridge setup so I am excited about putting this into real use.

Having now started my kegerator build I added another 4 taps so bought an Arduino Mega to make use of the 6 tap system.

However the Android App does not register the mega as a Controller. I can swap in the Duemilanove (even without the flow meters attached) and the App immediately registers it.

Do I need to edit the Arduino Kegboard Sketch in some way or add anything to the Mega Board to make it work?


#3

Hi, you can turn of DEBUG in the settings file to bring the controller up.

I’m not sure why it isn’t reporting as more than 2 flow meters by default.


#4

Thanks mate, I have not touched it since so I will have another look now to see if I can get it to work


#5

You also have to manually add the flow meters. I am using a rpi and not the app as the server FYI


#6

Just to close the loop (maybe) I could not get a mega recognised by the tablet app which is a shame as I was hoping to use NFC with more than 2 taps


#7

Thanks moad, I must get round to revisiting this. I spent a lot of time first time round and failed


#8

I’ve just tried my genuine mega that has a serial set and it did work with the app!

I’m going to try setting a serial on my other mega I was trying with, will report back


#9

Hi Geoff,

That worked!

So you will need to have a kegbot server installed (a good idea anyway as the feature set is limited without one) and then install the support tools (pip install kegbot-kegboard) then it will be in /usr/local/bin

set-kegboard-serialnumber

hope this helps you and anyone else.

Cheers,

Moad


#10

Nice one Moad, you have given me renewed enthusiasm

Cheers
Geoff