Arduino not working on tablet

I have a kegberry setup on a raspberry pi 2 and i have an arduino uno with the kegboard firmware. My flow meter work when the arduino is connected to the raspberry pi though usb. But kegbot app on android doesnt see the board or the flow meters. I have checked a USB info app and it finds the board plugged into the usb through otg cable. I have looked all over the forums and tried a bunch of things.

Im using a nexus 7 2013 with 4.4.4 and flashed the kernels. I have used a few apps to verify usb host.

I might be missing something, Do you need a kegboard shield for an arduino to work with the tablet?

The arduino should be connected to the tablet via USB and the OTG cable. The pi will be a stand alone server and connected to your home network via lan or wireless

EDIT: I may have misunderstood…are you connecting the arduino to the tablet ONLY? No OTG-Y cable…just an OTG cable?

I originally connected the arduino with flow meter to the pi and it worked and logged drinks. I connected the arduino to the tablet using an otg-y cable and the lights on the board come on and the tx activity light lights up when you test the flow meter but the kegbot app doesnt see it.

Hmmm. Mine did that once when I had inadvertently changed the name of my flow meter in the server.

Only other things I can think of are 1, be sure to connect the OTG to the arduino first, wait a couple seconds, and then connect to the tablet. I remember people saying that was in issue. 2, maybe a faulty OTG cable…but it seems unlikely if a USB app sees the board.

Try searching the older forum. I know there were posts in the old forum regarding some issues like that…at least similar problems.

If Mike is still lurking around you might ask him. He had me create a report from my tablet and email it to him. He searched through it and pointed me to the fact that my flow meter was named wrong. I don’t see a lot of posts from him anymore. I think he’s busy with other stuff now.

Also, look here…may be something simple

Do you happen to remember how to make that report? it might help to look at

In the app click on the three dots in the upper right. Tap Bugreport. Here’s the deal…it’s gonna go to mike. I’m sure it saves somewhere on the tablet but I have no idea where. It’s a shame that he’s not around much. He fixed this problem in one night for me via this method. I hope it might help you.

Maybe the guys on the IRC channel could help. They are waaaaayyyy smarter than I am

I bought a Arduino Duemilanove Board and now it works. Something must be wrong with my uno board

I’m having the same problem with my Arduino Uno. The TX light works when I test the meter but the tablet (Acer A210 Android 4.1.1) doesn’t recognize the board. It doesn’t even see that a flow meter is attached. If there is something that causes the UNO not to work, I don’t have a problem buying a different Arduino but is there a way I can verify that the tablet is seeing the board or not?

I googled it and some forums were saything that usb serial “chip” was the only difference between the two.

Well, I ordered a Duemilanove Board that should be here Thursday. I’ll let you know if it makes a difference. Fingers crossed

The Duemilanove board works great. With other people syaing that the Uno boards are fine, I guess there may be something up with a current batch of them. Either that or I got a bad knock off…