Cant get two taps working

Trying to get 2 taps working off a powered hub. I have 2 KBPM with a nexus 7 (2012). I can not get the tablet to see anything from the hub, it will charge the tablet but none of the KBPM’s will show up. Both KBPM will work if i plug them into the y cable.

this is the the usb hub im using

I can verify that the above hub works, however I much like others here, have experienced the KBPM shutting itself down after what appears to be a random amount of time. Have you tried connecting the whole system, then disconnecting the tablet from the rest of the system (hub still powered and connected to KBPM) then plugging the tablet back into the system… I have to do this usually once a day to keep the taps connected

also, I just read the that you have the hub powering the tablet, the tablet should be powered from the usb otg connection, not the hub, the tablet should connect to via the hubs input side

Tryed another hub, still nothing. How picky is kegbot for hubs?

In theory it shouldn’t be picky at all, and like I said mine worked right from the start. Maybe I was just lucky there. Can you get one tap to work with the hub installee?

nope, nether will work in the hub. they both work fine plugged to the tablet

OK and not to insult you intelligence, but the hub is connect to the tablet just like you would connect it to a computer? If it is, then it looks like it would be the hub.

Also try disconnecting the tablet with the kbpm plugged into the hub. Then reconnecting the tablet. That seems to do some sort of reset that I haven’t figured out yet, but I have to do it from time to time to make the tablet see the hub and kbpm

I ordered the hub you use, so hopefully that fixes it all. thanks

Best of luck. Another thought, when you connect the kbpm directly to the tablet did you use the USB otg cable? Test the mini through the otg, it could be a bad cable

Nexus 7 has a hardware limitation that it can only read data (USB Host Mode) or charge at once. You can’t do both at the same time. You can flash a custom kernel to do this (I used ElementalX), but my results were not dependable. It would charge and read from the KBPMs connected to a hub, but then flake out and lose connection after an hour or so. I came to the conclusion that the Nexus 7 WILL NOT work in a sustained fashion for more than one KBPM connected to a hub.

After banging my head against the wall for a month trying everything, I bought the Acer tablet that is recommended and it worked out of the box first try. I haven’t had any problems since.

Best of luck.

Hub works on the nexus 7. 2nd tap will not save my pours.

1 Like