Can't seem to upgrade Kegbot server.. ever

Okay so I have had this problem for awhile now so I am now deciding to see what I can do to fix it… Every time I have ever tried to upgrade my kegbot server (currently at 1.1.1) I can’t get past the first command ‘pip install --upgrade kegbot’ without using ‘sudo’ and naturally when I use ‘sudo pip install --upgrade kegbot’ that works but then I can’t run ‘kegbot upgrade’ as it always errors out, breaks my server and then I have to restore from backup.

Can anyone tell me why I can’t simply type ‘pip install --upgrade kegbot’ without getting “permission denied”?

Thanks!!!

Jeff

pip in a virtualenv does not require sudo. See the install guide for details.

(The kegberry tool sets up a virtualenv for kegbot, if you’re using that. In essence it just wraps and hides a lot of the steps for you.)

Fair enough and during the initial server build process I’m going the route detailed in the install guide so far as creating and entering the virtualenv. My question is how do I get back into that virtualenv now that I have rebooted and such? Maybe I’m just missing something obvious is all…

Thanks!!!

Jeff

try this maybe?

[email protected]:~# su - kegbot
[email protected]:~$ . kegbot-server.venv/bin/activate
(kegbot-server.venv)[email protected]:~$ pip install --upgrade kegbot
(kegbot-server.venv)[email protected]:~$ kegbot upgrade

I give up… I guess I’ll just build a new server every single time I want to upgrade. Even in the virtual environment which I activated by running ‘source /data/kb/bin/activate’ I still get the same permission denied error. Specifically I get a lot of red TXT that means nothing to me then at then end I see “OSError: [Errno 13] Permission Denied: ‘/data/kb/build’”.

I follow the directions provided to a T in the kegbot server install guide with only my username being different then ‘kegbot’ so I’m not doing anything that’s out of the ordinary yet I have this problem every single time I build a kegbot server. From doing a ton of reading on the kegbot forums and such I must be doing something inherently wrong as it appears to be “just me”. I just can’t figure out what I’m doing wrong…

Jeff

Sorry I didn’t reply to this directly but I can’t get past ‘. kegbot-server.venv/bin/activate’ as it says no such file or directory exists.

Thanks!!!

Jeff

Jeff, and that’s after you have changed to the kegbot user? If so, sorry past my knowledge level.

I finally figured out what the problem is, despite following the directions provided to a tee all the folders for kegbot were created with “root” as the owner and the only one that could make changes. I fixed the ownership to my user account and now I can run the ‘pip install -U kegbot’ and ‘kegbot upgrade’ without issues but the upgrade to 1.2 broke my server completely and now I’m dead in the water…

Thanks
Jeff

Dont know man,

I would start fresh. Do you have a 1.1.1 backup?

Fresh droplet

export INSTALLFLAGS="–nopycore --allow_root"
bash -c “$(curl -fsSL https://raw.github.com/Kegbot/kegberry/master/install.sh)”

Then do first time setup wizard.

Then restore from your 1.1.1 backup

[email protected]:~# su - kegbot
[email protected]:~$ . kegbot-server.venv/bin/activate
(kb) $ kegbot restore /path/to/old/backup

Make sure everything’s hunky dory. Then time to upgrade to 1.2

(kb) $ pip install -U kegbot
(kb) $ kegbot upgrade

These are the exact steps I used migrating from a raspberry pi and then upgrading to 1.2.

@jeff200883 did you update the kegbot.conf file after your upgrade? See this post for new settings to replace the current settings. Kegbot Server v1.2 Released