Digital ocean and server v1.2.1

Has anyone experienced the need to power cycle the server almost daily when using the smallest droplet? Didn’t happen before the upgrade, and it doesn’t seem to be needed when running the droplet one size larger.

Just to add a bit more info, I get a server error 500, and my tablet won’t pull server stored info such as user accounts until I do a power cycle, or use
[email protected]:~$ reboot.

I have been using the smallest droplet on Digital Ocean without the issues you mentioned, but I have been experiencing problems where not all pours show up on the tablet activity feed or register in the drink database on the server. Have you had that happen as well?

Nope all pours register for me

When you SSH into your droplet and see the ‘Memory usage’ stat at the welcome message, what is that sitting at? Mine is at 87%, which seems a bit excessive to me.

Mine sits at about 19%. 87 does seem really high. Are you running it with Ubuntu 14.04 x64??

Correct, 14.04 x64. I ran htop and see mulitple instances of various processes but will post the screenshot of that in the other thread I started as to not hijack yours. I appreciate your input thus far.

May be easiest to export the data, kill the droplet, and reinstall the server to get rid of the multiple processes. If you do that, I found I had to resize my droplet up one to do the server upgrade from 1.1.1. Afterwards you always size it back down if you don’t feel like spending $10 a month.

Another update… I did an SSH into the server when it was giving the server 500 error and I noticed memory usage was up to 90%. After reboot it was back down to the teens. I wonder what is causing it. Its a bit frustrating rebooting daily.

I now have the exact same issue, I have not really tried troubleshooting it yet, I will next time i get the 500 error. Mine lasts for 4-6 days without a reboot though however otherwise exactly the same as you Josh.

well another update I am getting the 500 error, but this time when I ssh I am sitting at memory usage of 10% so I am not sure if that is the problem anymore.

So for testing purposes, I have upped my droplet size to the $10 a month, and we are nearing 24 without a reset.

So the larger droplet has proven to work. I have yet to restart, but I am going to ride it out the rest of the week to make sure.

This leads me to believe a hardware issue. Anyone want to weigh in?

Do not know, doesn’t really make sense it’s hardware as mine just bugged out again, checked the stats, only 9% ram usage, barely any CPU (this is smallest droplet size). Also I am running other services on this droplet as well (mumble server and FTP) They are still working without issue. Don’t know where to go from here.

I have yet to need to restart the server since moving to a $10 droplet. Kind of sucks BC the smallest droplet should have enough power to run things.

Yea I know what you mean. I can live with having to restart weekly as I have a tasker android script setup to ssh and reboot. Save the $60 / year difference for something else :wink:

ekrizon,

just wondering, do you have google analytics running on your server? Now that aI’m thinking about it, it seems that my issues started around the time I started using it, not sure if it connected at all, I’m just fishing for a cause.

Nope.

Hmmm back to the drawing board.

have y’all tried adding swap? it shouldn’t hurt, and RAM may be the difference.

here’s digital ocean’s guide for adding swap on ubuntu.