Do you need help with digital ocean?

Those of you that have been having issues getting their bots started on digital ocean -502 error. I have listed the steps on various posts on this site. If your are still having trouble getting into the site to run the wizard. You can create a new droplet and pm me the info that digital ocean sends you. I’ll run the install script and edit you kegbot.conf file to get you up and running.


When I installed my server on Digital Ocean I also had big problems. If this opportunity would have been offered then I would have grabbed it :smile:

joshuawhite5522 shows what a forum is all about…


I don’t have many answers here, but I’d like to spare some one the headache I went through getting mine up and running if I can.

yes please, I need help to get my bot up and running, 2 weeks and still not running, I used the digital ocean last nite, and still no kegbot.

OK so you have a digital ocean droplet, and you ran the install script:

export INSTALLFLAGS="–nopycore --allow_root"
bash -c “$(curl -fsSL”

Then you need to type:

nano /etc/supervisor/conf.d/kegbot.conf

Replace what is there with this section of code mineus the " at the start and finish

"### Supervisor.conf for Kegbot – Kegberry edition.


command=/home/kegbot/kegbot-server.venv/bin/gunicorn pykeg.web.wsgi:application -w 3

command=/home/kegbot/kegbot-server.venv/bin/kegbot run_workers

Then hit ctrl x to exit- it will ask you to save press Y
it will then ask you what to name the file - just hit enter so it dosent change the file name

then type reboot and wait 60 seconds

now try to access your webserver via your broswer to run the setup wizard for the server and you should be good to go. The URL should look something like this ( this is also what you will put into your tablet app)
If you did all this with no luck, you can destroy your droplet and create a new on then pm me the info digital ocean sent you in the email and I’ll set it up for you. It seems that the majority of people are having issues trying to get the website open to run the setup wizard. I can have the server up and running for you in about 15 minutes.

Thanks for your help in the past. I may take you up on this offer if I try to tackle the server again. Im happy with my kegbot now that it is calibrated and running well on my touchpad. My main reason for a server is to get rid of that keg with the ? and have a picture of the beer I am tapping.

Just let me know.

I made a video of how to do the install via putty for windows. Hopefully this helps some of you. You can view it on YouTube here:

1 Like

Success thanks!

I was even able to edit the volume left with spilled volume in keg admin.
How do I change debug mode?

type: su - kegbot

type: nano ~/.kegbot/

You can then delete the word true and type false in its place.

thank you so much. I got it working. How do you debug it? I did what it said on kegbot and it dosent work. Besides that everything was so easy to set up because of your video. Now I can enjoy my kegbot. Thanks again.

Another user noticed the edit needed for the file

Diear Joshua I am Guillermo from Costa Rica and I have been following your instructions to run Kegbot on digitalocean but I have been getting an error and I do not know what else to do.

Can you helpme run kegbot?

What is the error you are getting

one I copy step 3. and run it I get … importerror: no module named sixC

  • sudo bash -c 'DEBIAN_FRONTEND=noninteractive apt-get -yq install python-setuptools’
    Reading package lists…
    Building dependency tree…
    Reading state information…
    python-setuptools is already the newest version (20.7.0-1).
    The following package was automatically installed and is no longer required:
    Use ‘sudo apt autoremove’ to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • sudo easy_install pip
    Searching for pip
    Best match: pip 9.0.1
    Processing pip-9.0.1-py2.7.egg
    pip 9.0.1 is already the active version in easy-install.pth
    Installing pip script to /usr/local/bin
    Installing pip2.7 script to /usr/local/bin
    Installing pip2 script to /usr/local/bin

Using /usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg
Processing dependencies for pip
Finished processing dependencies for pip

  • sudo pip install -U virtualenv
    Requirement already up-to-date: virtualenv in /usr/local/lib/python2.7/dist-packages
  • sudo pip install -U --pre kegberry
    Requirement already up-to-date: kegberry in /usr/local/lib/python2.7/dist-packages
    Requirement already up-to-date: python-gflags in /usr/local/lib/python2.7/dist-packages (from kegberry)
  • kegberry --nopycore --allow_root install
    Traceback (most recent call last):
    File “/usr/local/bin/kegberry”, line 4, in
    from kegberry import app
    File “/usr/local/lib/python2.7/dist-packages/kegberry/”, line 19, in
    import gflags
    File “/usr/local/lib/python2.7/dist-packages/gflags/”, line 58, in
    import six
    ImportError: No module named six

What version of Ubuntu is your droplet? Make sure it is 14.04 x 64

Thanks a lot Joshua. Now I have to start with the set up.

Once I chance the ubunto your script run smoothly

Thanks a lot

Hi Josh. Can you help me get my server up and running? I was able to get it to a point where I can access the web page but for some reason, it doesn’t consistently record pours. Is there a log file I can watch to see incoming API requests? Could you take a look? Thanks in advance.

Not consistently recording pours? Hard to say from that.Give me a little background, what does your system look like? how many taps, what kind of tablet, what kind of controller (kbpm, Arduino, particle)?

So I purchased the kit from and have two taps but only one keg setup right now. When I pour a beer, the tablet detects that it’s pouring and allows me to assign a user, take a picture, and complete the pour. But that’s all it does. I think the actual service call is failing but I only recently turned on debug mode to monitor.