Error - RASPI install error


#1

Hi All,

I am very new to RASPI and linux in general so please bear with me.

I just ran the BASH script to install the kegberry server but I am getting the following error… can anyone help?

INFO : Updating package list …
INFO : Installing required packages …
Reading package lists…
Building dependency tree…
Reading state information…
Package libmysqlclient-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
mysql-server-5.5

E: Package ‘libmysqlclient-dev’ has no installation candidate

ERROR : Command returned error:
ERROR : Command: sudo bash -c "DEBIAN_FRONTEND=noninteractive apt-get -yq install build-essential nginx-light libjpeg-dev supervisor python-setuptools python-dev libmysqlclient-dev mysql-server redis-server"
ERROR : Return code: 100
Traceback (most recent call last):
File “/usr/local/bin/kegberry”, line 7, in
app.run()
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 210, in run
command_fn(*args)
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 242, in install
self._update_packages()
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 235, in _update_packages
’ '.join(REQUIRED_PACKAGES)))
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 142, in run_command
raise e
subprocess.CalledProcessError: Command ‘sudo bash -c “DEBIAN_FRONTEND=noninteractive apt-get -yq install build-essential nginx-light libjpeg-dev supervisor python-setuptools python-dev libmysqlclient-dev mysql-server redis-server”’ returned non-zero exit status 100


#2

@mike - are the install packages still working? I am looking and the last time that there were updated were 2014/2015.

I tried to use the PI custom image but my PI would not boot.
Next, I installed the latest raspian OS and used the bash method above.
lastly I tried to use the step by step instructions on the kegbot server page, but am now getting the following errors…

(KB) pi@raspberrypi:~ $ pip install -U kegbot
Collecting kegbot
Using cached kegbot-1.2.3.tar.gz
Collecting kegbot-pyutils==0.1.7 (from kegbot)
Using cached kegbot-pyutils-0.1.7.tar.gz
Collecting kegbot-api==1.1.0 (from kegbot)
Using cached kegbot-api-1.1.0.tar.gz
Collecting Django<1.8,>=1.7 (from kegbot)
Using cached Django-1.7.11-py2.py3-none-any.whl
Collecting django-imagekit==3.1 (from kegbot)
Using cached django-imagekit-3.1.tar.gz
Collecting django-registration==1.0 (from kegbot)
Using cached django-registration-1.0.tar.gz
Collecting django-socialregistration==0.5.10 (from kegbot)
Using cached django-socialregistration-0.5.10.tar.gz
Collecting django-bootstrap-pagination==0.1.10 (from kegbot)
Using cached django-bootstrap-pagination-0.1.10.zip
Collecting Celery==3.1.17 (from kegbot)
Using cached celery-3.1.17-py2.py3-none-any.whl
Collecting django-crispy-forms==1.2.8 (from kegbot)
Using cached django-crispy-forms-1.2.8.tar.gz
Collecting foursquare==2014.04.10 (from kegbot)
Using cached foursquare-2014.04.10.tar.gz
Collecting gunicorn==19.1.1 (from kegbot)
Using cached gunicorn-19.1.1-py2.py3-none-any.whl
Collecting MySQL-python==1.2.5 (from kegbot)
Using cached MySQL-python-1.2.5.zip
Complete output from command python setup.py egg_info:
sh: 1: mysql_config: not found
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-_V3mb4/MySQL-python/setup.py”, line 17, in
metadata, options = get_config()
File “setup_posix.py”, line 43, in get_config
libs = mysql_config(“libs_r”)
File “setup_posix.py”, line 25, in mysql_config
raise EnvironmentError("%s not found" % (mysql_config.path,))
EnvironmentError: mysql_config not found

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-_V3mb4/MySQL-python/

I seen a post that you were working on a 1.3 version… is this something I can use to help get past these errors?

thanks for your help!


#3

I’ve been going through this myself. The packages aren’t updated for debian strech. I’ve opened a PR for the issues I’ve run into myself: https://github.com/Kegbot/kegberry/pull/20

I’m currently working on a python script to run, read from the Adafruit flow meters, and spit data back to kegbot-server. It’ll likely be a few days before I have anything cobbled together, but I’ll post it up here when it’s done.


#4

That is great news!

I was able to flash my Arduino board and it looks to be working, but I will not know for sure until I plug it all in together.

I am using the SF800 meters.


#5

Hi Guys,

Any update on this? I am familiar enough with this stuff to make the changes myself… My keezer is definitely not as cool as it should be right now ;-p

thanks!!!


#6

Hi, I’m having the exact same issue.Got my arduino flashed and wired with sensors, lights and whatnot. It appears to be working perfectly. But flashing the custom image to an sd results in black screen & no green blinky light on any of my pi’s. Running the BASH script from a fresh install of raspbian results in the libmysqlclient-dev error. Any word on a workaround?


#7

I ended up needing to go with digital ocean.

I think the issue is with newer PI’s as these scripts we built 3 years ago.

Let me know if I can help, I just got mine working but still getting the kinks out.


#8

Thanks for getting back to me!!! And, the offer of help. I’m a little confused by what you mean about going with digital ocean. Does that mean you uploaded a different image over there? The booting problem while running the custom image from kegbot is definitely a conflict with new pi and the old wheezy OS. I just tried a 2014 version of that with the intention of running the bash command from there… No boot, black screen, no blinky green light.


#9

Exactly the problem I had.

Digital ocean is a server platform online that you can run the kegbot server on instead of the raspberry Pi. There was an article posted about a month or two on here along with a YouTube video that worked perfectly for me.


#10

Cool, thanks for the help! That is a helpful video, but I’m stuck on the idea of running it on a pi. Hopefully I can figure out how to do that. I’ll update if I’m successful. Here’s a link to the video in case anyone else is interested. https://www.youtube.com/watch?v=7H_3kmey15g


#11

I cut my losses and turned it into a retropi emulator :slight_smile:

I think if you have the Pi2it will work.

I tried use the old config files but it would get stuck on the rainbow screen


#12

Have you seen this? https://github.com/ogreface/kegberry/tree/strech_updates
It looks like it should solve the problem. I downloaded it to my pc. But I’m too new at all of this to figure out what to do with it from there.


#13

Just an update: I tried this,

bash -c “$(curl -fsSL https://raw.github.com/ogreface/kegberry/strech_updates.sh)”

It returned the same errors. So, I did this,

sudo bash -c “DEBIAN_FRONTEND=noninteractive apt-get -yq install build-essential nginx-light libjpeg-dev supervisor python-setuptools python-dev mysql-common mysql-client mysql-server redis-server”

No errors returned! And, when I go to the Pi’s ip address from another screen I get,

“Welcome to nginx! If you see this page, the nginx web server is successfully installed and working” Further configuration is required"

So, it seems like progress…?


#14

You are already ahead of me on Linux hahah!