Flashing firmware to KBPM fails

I have tried the following scenarios in order to flash my kbpm.

Windows 8.1 x64
Arduino latest
Arduino 1.0.4
Special keboard version of arduino
Various different USB cables.

Every time in windows the Arduino software halts at "Uploading…"
When I disconnect I get the message:|
avrdude: ser_send(): write error: sorry no info avail

in Arduino 1.6.3, the sketch won’t compile at all.

To try work around my windows problem I installed the arduino/kegbot software to my raspberry pi directly from source as well as the kegboard sketch files.

Unfortunately i hit a snag with /bin/sh as raspbian uses dash instead of bash by default. Once I changed that, I was able to get the sketch to make clean and make successfully.

When I use make upload, depending on how soon after I plug in the kbpm I get one of the two following outputs:
If i run make immediately after plugin:

\nUploading to board…
stty -F /dev/ttyACM0 speed 1200
sleep 1
/usr/bin/avrdude -v -DV -p atmega32u4 -P /dev/ttyACM0 -c avr109 -b 57600 -U flash:w:kegboard.hex:i

avrdude: Version 5.11.1, compiled on May 23 2012 at 11:08:25
Copyright © 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright © 2007-2009 Joerg Wunsch

     System wide configuration file is "/etc/avrdude.conf"
     User configuration file is "/root/.avrduderc"
     User configuration file does not exist or is not a regular file, skipping
     Using Port                    : /dev/ttyACM0
     Using Programmer              : avr109
     Overriding Baud Rate          : 57600
     AVR Part                      : ATmega32U4
     Chip Erase delay              : 9000 us
     PAGEL                         : PD7
     BS2                           : PA0
     RESET disposition             : dedicated
     RETRY pulse                   : SCK
     serial program mode           : yes
     parallel program mode         : yes
     Timeout                       : 200
     StabDelay                     : 100
     CmdexeDelay                   : 25
     SyncLoops                     : 32
     ByteDelay                     : 0
     PollIndex                     : 3
     PollValue                     : 0x53
     Memory Detail                 :
                              Block Poll               Page                       Polled
       Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
       ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
       eeprom        65    10     8    0 no       1024    8      0  9000  9000 0x00 0x00
       flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
       lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
       signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00
     Programmer Type : butterfly
     Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
make: *** [upload] Error 1

Or If I try make after waiting some time once plugged in.

\nUploading to board…
stty -F /dev/ttyACM0 speed 1200

To which it hangs forever.

I have 2 different KBPM and they both behave the same.

When powered, the power LED illuminates immediately, followed by RX after a second which remains on permanently. I’m yet to see either of the TX or CHIP LED light up.

Has anyone actually successfully flashed the firmware onto kbpm under windows 8.1? If so, are there instructions to follow that don’t skip the actual tricky parts?

I’ve probably burned about 10-15 hours on this section of the project so far and I’m at a loss for completing what was supposed to be the easiest part!



@ravenge sorry for the trouble here; it’s not something most people have had to do. The KBPM is shipped pre-flashed – definitely not a problem if you want to flash it (hack away!), but just wanted to be sure you were aware.

Have you seen the steps on the wiki? I unfortunately don’t have a windows box to test with, but perhaps you’ll be able to translate the important aspects.

Here’s the wiki: https://github.com/Kegbot/kegboard/wiki/How-to-flash-a-KBPM

I was expecting the kbpm pre-flashed however when I went to use them no controller was detected. Following the troubleshooting:

Verify the Kegboard Pro Mini
Before connecting anything, let’s verify that the Kegboard Pro Mini and your flow sensor are in good working order.

There are four LEDs on the left side of the board. From top to bottom, they are:

POWER: Board-level power indicator, just about the USB connector.
RX: Serial data receive LED.
TX: Serial data transmit LED.
CHIP: General-purpose board LED.
Connect the board to any USB power source. The POWER LED should light up.

Shortly after power-up, the CHIP LED should flash and decay on a 5-second cycle. This means the Kegboard firmware is listening.

Now connect the flow sensor to the KegJack. Run a small amount of water through the sensor; you can also blow on it, gently. Either should cause the flow sensor’s turbine to spin, and one or both of the RX and TX LEDs should blink.

If these both succeed, you’re ready to move on! If not, see Troubleshooting.

I can tell you that when connected to any usb power supply, ONLY the power LED illuminates. From this I presumed that the firmware is non-existent or flashed incorrectly. I have never seen the CHIP led illuminate.

As mentioned in the post, I get this message when trying to flash:

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding

or it just hangs on uploading forever.

Oh, that’s definitely not cool! Drop us a line at [email protected] with your old order number and, if you can, the serial number. That will help us track the bad item and trace it back to a batch. And of course, get you a replacement!



Hopefully this can be resolved soon as I have a nice cold 19L Keg of homebrew that I’m dying to try out!

Geoff (ravenge)

Hi Mikey,

Unfortunately I’ve not heard back after dropping a line to [email protected] with the details you requested.

Any advice?


Replied, sorry for the delay.