Help to enable extrernal access


I’m sure this is a very basic question but this is my first contact with raspberry, linux, etc… So far I already have my kegbot server working, linked to my tablet, with twitter and email config and accessible from every device conected to my LAN (believe me, this has been a great challenge for someone that didn’t studied anything of programming or networking). But this has been by far one of the best diy projects.

I’m officially stuck on external access config, I’ve read everything on this forum related to this topic and I’m pretty sure I’m missing a basic command.

This is what I’ve tried:

What I’am missing? How can I assign port 80?

I already config the router to enable port fowarding and DDNS to PI’s IP, I just need to asign the port to make my server open to external computers.

BTW: I’ve already tried:
(kb) $ kegbot runserver
With no success as well.


When you access your server from your LAN what port do you connect on?

In the screenshots you will need to enter the virtualenv to use the kegbot commands.

To access the server from the LAN I just enter the Pi´s IP address, in this case without adding any port, so I assume automatically is using port 80 or I need an additional config?

I´ll try the virtualenv command once I´m in front of the Pi at home.


You will need to enable port forwarding through you router at home. A quick google search should give you the info you need to set it up on you brand of router.

Thanks! Apparently on:
shows that my 80 is closed even if I configure it on my router to open it for my Pi´s IP (I imagine that my ISP has blocked those ports on the router). on the same webpage it shows that the port 8080 is open on my IP. I just need to set my Kegbot Server to point to port 8080, any ideas on how to do this?


I wet with my ISP and change their router for a simple modem. Now I was able to do all configurations easily with my Asus router and now I have external access.