Installation issues with automated install


#1

Hey everyone, I tried installing kegberry using the automated installation and try as i might, i keep failing.
this is on a fresh raspbian image from NOOBS

here is the entire output

i@raspberrypi:~ $ bash -c “$(curl -fsSL https://raw.github.com/Kegbot/kegberry/master/install.sh)”

  • sudo bash -c 'DEBIAN_FRONTEND=noninteractive apt-get -yq install python-setuptools’
    Reading package lists…
    Building dependency tree…
    Reading state information…
    python-setuptools is already the newest version.
    python-setuptools set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • sudo easy_install pip
    Searching for pip
    Best match: pip 1.5.6
    Adding pip 1.5.6 to easy-install.pth file
    Installing pip script to /usr/local/bin
    Installing pip2.7 script to /usr/local/bin
    Installing pip2 script to /usr/local/bin

Using /usr/lib/python2.7/dist-packages
Processing dependencies for pip
Finished processing dependencies for pip

  • sudo pip install -U virtualenv
    Downloading/unpacking virtualenv
    Downloading virtualenv-14.0.3-py2.py3-none-any.whl (2.2MB): 2.2MB downloaded
    Installing collected packages: virtualenv
    Successfully installed virtualenv
    Cleaning up…
  • sudo pip install -U --pre kegberry
    Downloading/unpacking kegberry
    Downloading kegberry-2.1.1.tar.gz
    Running setup.py (path:/tmp/pip-build-gDR7Yz/kegberry/setup.py) egg_info for package kegberry

Downloading/unpacking python-gflags (from kegberry)
Downloading python-gflags-2.0.tar.gz (65kB): 65kB downloaded
Running setup.py (path:/tmp/pip-build-gDR7Yz/python-gflags/setup.py) egg_info for package python-gflags

Installing collected packages: kegberry, python-gflags
Running setup.py install for kegberry

changing mode of build/scripts-2.7/kegberry from 644 to 755
changing mode of /usr/local/bin/kegberry to 755

Running setup.py install for python-gflags

Successfully installed kegberry python-gflags
Cleaning up…

  • kegberry install
 oOOOOOo
,|    oO  Kegberry v2.1.1 - http://kegberry.com

//| |
\| | “It takes beer to make thirst worthwhile.”
| | -- German proverb-----`

INFO : Updating package list …
INFO : Installing required packages …
INFO : Cleaning up …
INFO : Checking if database exists …
INFO : Creating database …
INFO : Installing MySQL timezones …
INFO : User “kegbot” does not exist, creating …
INFO : Checking/installing virtualenv “kegbot-server.venv”…
INFO : Checking/installing virtualenv “kegbot-pycore.venv”…
INFO : Installing python server packages, this may take a while …
Collecting kegbot==1.2.3
Downloading kegbot-1.2.3.tar.gz (3.2MB)
Exception:
Traceback (most recent call last):
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/basecommand.py”, line 209, in main
status = self.run(options, args)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/commands/install.py”, line 310, in run
wb.build(autobuilding=True)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/wheel.py”, line 747, in build
self.requirement_set.prepare_files(self.finder)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/req/req_set.py”, line 359, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/req/req_set.py”, line 576, in _prepare_file
session=self.session, hashes=hashes)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 809, in unpack_url
hashes=hashes
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 648, in unpack_http_url
hashes)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 870, in _download_http_url
_download_url(resp, link, content_file, hashes)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 594, in _download_url
hashes.check_against_chunks(downloaded_chunks)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/utils/hashes.py”, line 46, in check_against_chunks
for chunk in chunks:
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 566, in written_chunks
for chunk in chunks:
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/utils/ui.py”, line 139, in iter
for x in it:
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/download.py”, line 555, in resp_read
decode_content=False):
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py”, line 344, in stream
data = self.read(amt=amt, decode_content=decode_content)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py”, line 311, in read
flush_decoder = True
File “/usr/lib/python2.7/contextlib.py”, line 35, in exit
self.gen.throw(type, value, traceback)
File “/home/kegbot/kegbot-server.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/response.py”, line 240, in _error_catcher
raise ReadTimeoutError(self._pool, None, ‘Read timed out.’)
ReadTimeoutError: HTTPSConnectionPool(host=‘pypi.python.org’, port=443): Read timed out.

ERROR : Command returned error:
ERROR : Command: sudo su -l kegbot -c ". /home/kegbot/kegbot-server.venv/bin/activate && pip install kegbot==1.2.3"
ERROR : Return code: 2
Traceback (most recent call last):
File “/usr/local/bin/kegberry”, line 7, in
app.run()
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 210, in run
command_fn(*args)
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 281, in install
run_in_virtualenv(SERVER_VENV, ‘pip install {}’.format(FLAGS.kegbot_server_package))
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 154, in run_in_virtualenv
return run_as_kegberry(cmd, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 148, in run_as_kegberry
return run_command(wrapped, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line 142, in run_command
raise e
subprocess.CalledProcessError: Command ‘sudo su -l kegbot -c “. /home/kegbot/kegbot-server.venv/bin/activate && pip install kegbot==1.2.3”’ returned non-zero exit status 2
pi@raspberrypi:~ $

if anyone has any input i’d greatly appreciate it


#2

I just did a few Raspbian installs, but I didn’t use Noobs. Here’s the process I followed that worked great for me:

  1. Download a fresh copy of Raspbian Jessie
  2. Flash it to the SD card using Win32DiskImager
  3. Log in via PuTTy, run sudo raspi-config and expand you disk volume
  4. Run sudo apt-get update && sudo apt-get upgrade
  5. Run sudo rpi-update

One that’s all done, then try the kegbot install script. I think I did this 3-4 times over the past few weeks and didn’t have any issues.


#3

i tried again this morning successfully. the only difference i had was when running the automated script was to use a wired connection instead of wireless.

not that that should have any difference unless you suddenly lose connection, which is likely the case here, the wireless sucks.

thank for your input !


#4

I have this same error whether I am on wired or wireless connection. Tripub - I’d like to try your solution but don’t really know enough about this stuff. I have the newest version of Rasbian Jessie on my SD card and it works on my raspi. Tell me about PuTTy and how I log in?


#5

PuTty is just a SSH client to log in. If you are using a keyboard/mouse/monitor you shouldn’t need it. If you do want to use it, it’s a free download.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Just put in your Pi’s IP address and log in with your username and password, then follow the steps above.


#6

I just used a keyboard/mouse/monitor with the raspi. My problem was not expanding the disk volume first. Made sure to do that, as well as apt-get update, apt-get upgrade, and rpi-update. Works great now. Thanks for the help.

One last question. Now that I can see everything on the web interface, is there a way to run everything there without having to use a tablet for the app? For example, how do I log pours? How does it know which user is pouring if there’s no app running?


#7

I’m curious if anyone else has advice on this problem. I’m running into the same exact problem as Turbo. I’ve tried wireless and wired and have the same error. The list volume is expanded, I ran apt-get update, apt-get upgrade and the rip-update. Still hitting the exact same error. It’s appears to be the same as above but here are the last couple lines when it drops out.

File “/usr/local/lib/python2.7/dist-packages/kegberry/app.py”, line
142, in run_command
raise e
subprocess.CalledProcessError: Command ‘sudo su -l kegbot -c “.
/home/kegbot/kegbot-pycore.venv/bin/activate && pip install
kegbot-pycore==1.2.0”’ returned non-zero exit status 1

Thanks for the help.


#8

I had a similar issue a while back and had to resort to moving away from PI to Digital ocean. From what I can gather from all the comments it is an issue with the new software on the PI’s. If you can find an old PI2 or downgrade the software it may work.