Kegberry/Kegbot New Installation


#81

Soooo I got all the parts, thanks to @crankycowboy for the fittings!
Now I put everything together as you have instructed but I am getting an issue.
When I go into the Serial Monitor, I am not getting any readable data at baud 115200

I set up the kegbot admin and found the keg board with 2 flow meters, flow0 and flow1, I have 3 flow meters attached but I realized that only 2 showed up because when I flashed my arduino mega I didn’t change the number of meters from 2 to 3 under ‘kegboard_config.h’
Anyway, I wired everything correctly but when I blow into the meters, or run water out of my keg with a flow meter attached, I dont see any activity on the kegbot app. It does not show any oz poured.

I should note that unlike you, I used a cat7 ethernet cable and on the flow meter side instead of soldering the wires to the rj45, because i completely screwed up…, I got one of these. Not sure if that would make a difference?

Im pretty sure I wired everything correctly on the Arduino side and the flow meter side.
Not sure how to proceed.


#82

Oh… I think I need to solder this with a head pin to make connections between the screws and the port…? Lol I was trying to avoid soldering…


#83

@mhmatttu, I think you’ll also need to integrate some of my changes from the Kegbot-Pycore repository on Github, specifically the changes I committed on Aug 21, 2018. By default, Pycore does not publish an event with the username when an RFID token is scanned, so I added that feature.


#84

@sharpbeer, first off, those messages in the Arduino Serial Monitor look correct. Each message from the Arduino to the tablet (or Raspberry Pi if going that route) will have “KBSP v1:” and then some encoded string after that, so I’m not concerned there. The temperature messages and flow messages look slightly different and I think @mhmatttu has a good screenshot that illustrates that.

As far as the flow meters, the screw-terminal RJ45 adapter should work just fine, I was actually using one of those successfully as I was prototyping my build out. I would first connect your flow meters directly to the arduino to make sure they are working (maybe you’ve already done that) and then start testing with a cable in-between. I’m sure those screw-terminals are already connected to the pins on the RJ45 connector.


#85

Got it working when tested the flow meter connected directly to the Arduino, shows activity when I blow air into the flow meter on the serial monitor. Also, when I use it connected to the tablet it shows oz poured. It looks like I had the power wire plugged into the ‘5v’ on the board instead of the power connection… Dumb mistake haha. Now I have to set it all back up. Thanks.


#86

Thanks again @johnnyruz but I’m having trouble getting the flow meters and Arduino to communicate through the RJ45 adapters. If I plug the flow meters directly to the Arduino they work. When I throw the RJ45 adapters into the mix, they do not show any oz poured in the Kegbot app. I tried switching the ethernet cable out, cat7 with a cat6, but that didn’t help. Sorry to keep bothering you with this but I’m literally 1 fix away from getting this thing set up and going. Not sure how to proceed.
These are what the Arduino/flow meter endings look like:
Any suggestions on what I can try?


#87

@johnnyruz I appreciate your continued help with this. I have reviewed your Github repository and have all the latest updates implemented. Everything is working as you have described including live pour data, pours assigned to user based on rfid authentication, etc. The only missing part is the Welcome User message on the fullscreen page. Here is a screenshot of the logs from the web interface. I’m wondering if its not a API issue. I regenerated the API and updated the local_settings.py and node server config.js files with the new API Key, but i am still not getting the Welcome User message. Any thoughts are appreciated! Thanks.


#88

@sharpbeer,

Do you have a multi-meter? I would just check that you see 5 Volts across the power and ground pins on the far-side of the connector once you connected the cable. Also, if your meter has a continuity test, make sure you read continuity between across the signal pin across the cable.


#89

Thanks again for replying John. I actually just ordered another screw terminal rj45 to replace the solder type rj45. Got it yesterday and tried the cat7 between the two screw terminal rj45s and it worked. So, it seems either the one I replaced was broken or I had a bad connection on it somewhere, most likely my shoddy solder job.

I wont have time to get back to setting it up until Friday evening but it should all be good now. I’ll update on it this weekend.