Kegbot-server v1.1.1 released


#1

Mostly minor stuff; enjoy!

  • API: New endpoint: drinks/last.
  • Newly-created meters now default to FT330-RJ calibration values.
  • Kegadmin: Kegs can be deleted from the “Edit Keg” screen.
  • The kegbot restore command can run against an unzipped directory.

#3

Thanks Mikey for your hard work!

On digital ocean I just need to run from the virtual environment:
$ pip install --upgrade kegbot

Then
$ kegbot upgrade

Right?


#4

Same question, I have Digital Ocean and would like to install the new update. How do I do this?


#5

Try kegberry upgrade.

It’s a wrapper around kegbot upgrade (and basically does the steps @joshuawhite5522 mentioned, except running as the special kegbot user).


#6

And we run kegberry upgrade from the virtual env right?


#7

kegberry upgrade takes care of stepping into the virtualenv for you – once again, this is assuming you installed with kegberry install.

To put it another way, if you know where your virtualenv is and how to step into it, you can ignore the kegberry helper tool and just follow the upgrade procedure that you outlined.


#8

I installed mine by following the “
HowTo: Install Kegbot Server on Digital Ocean” instructions, so how do I proceed?


#9

@Mikey,

Has the new version not hit your servers yet because I’m trying to upgrade and I get an error that I already have version 1.1b2 installed.

 [email protected] // $ kegberry upgrade

     oOOOOOo
    ,|    oO  Kegberry v2.0.0b3 - http://kegberry.com
   //|     |
   \\|     |  "Who cares how time advances? I am drinking ale today."
    `|     |      -- Edgar Allen Poe
     `-----`

    INFO    : Checking for `kegberry` command update
    INFO    : Updating kegbot-server distribution ...
    INFO    : Updating kegbot-pycore distribution ...
    INFO    : Running `kegberry kegbot upgrade` ...
    Version 1.1b2 already installed.

I’ve tried upgrading both in the virtualenv and with the kegberry wrapper as posted above. Am I missing something?


#10

Sorry, hadn’t reached update servers. Give it another try?


#11

So just to get things straight…

If I installd using:
export INSTALLFLAGS="–nopycore --allow_root"
bash -c “$(curl -fsSL https://raw.github.com/Kegbot/kegberry/master/install.sh)”

Then all I need to use is:
kegberry upgrade

Right?


#12

Yes, that should do it.


#13

I tried running kegberry upgrade and ran into [sudo] password for kegbot: which I can’t remember. Is there a way around this?


#15

I’ve successfully updated to v1.1.1. I’ll see if my restore issue is resolved and post in the other thread with the results.

https://forum.kegbot.org/t/restore-from-backup-issues/?source_topic_id=205

#16

I’ve also successfully updated to v1.1.1. Thanks for the new updates!


#17

Thanks for this! Will I also need to update the tablet app or is this just a server-side upgrade?


#18

how did you get passed this? I have tried the only two passwords I have used on kegbot


#19

Hi @joshuawhite5522 ,

Sorry for the confusion. The kegbot user doesn’t have a password.

You should run kegberry upgrade as the default login user (root on Digital Ocean). The command handles running sudo when necessary – which root can do, but kegbot cannot.

Hope that makes sense. I’ll try to make this a little less painful in future revisions…


#20

I created my server on Digital Ocean and followed those instructions during setup so I started by using a portion of those instructions that briefly discussed upgrading. I typed in the following commands:

[email protected]:~# su - kegbot
[email protected]:~$ . kegbot-server.venv/bin/activate
(kegbot-server.venv)[email protected]:~$ pip install --upgrade kegbot

I then followed the pip install upgrade procedure from the link above in the thread from mikey. The first time I tried this it didn’t work, but out of frustration in trying other procedures and getting the “password” I tried it again and it worked. Not exactly sure why since I’m kind of flying by the seat of my pants when it comes to programming.


#21

so this is my issue doing it from the root

[email protected]:~# kegberry upgrade
Error: Do not run kegberry as root or with sudo.
[email protected]:~#


#22

ok so I ran it according to Jrod

[email protected]:~# su - kegbot
[email protected]:~$ . kegbot-server.venv/bin/activate
(kegbot-server.venv)[email protected]:~$ pip install --upgrade kegbot
(kegbot-server.venv)[email protected]:~$ kegbot upgrade

seemed to work for me here