Kegbot Server v1.2 Released


#21

I would like to revert back to v1.1.1 because I can’t get the new version working either, does anyone know how to do this on a Digital Ocean setup?

It would be great in the future if there was a “Check for Updates” button on the front end so users like myself who don’t really know their way around a database can have them automatically installed.


#22

Jrod,

Installing the server again will install a 1.1.1, you’ll have to destroy your droplet, create a new one, istall and restore from a back up. Now bear in mind I have yet to get the kegbot restore command to work right so try this at your own risk.


#23

joshuawhite5522,

Thanks for the feedback, I’ll give it a try.


#24

The backup format changed. In order to restore from this version, first install v1.1.1, then upgrade, ie:

(kb) $ pip install kegbot==1.1.1
(kb) $ kegbot restore /path/to/old/backup
(kb) $ pip install -U kegbot
(kb) $ kegbot upgrade

(This was mentioned in the release notes, although I will certainly sympathize that it’s an annoying surprise.)


#25

I finally got mine working :slight_smile: Thank you everyone for your help.
My procedure from within my working v1.1.1 server was to run the following four commands:

su - kegbot
. kegbot-server.venv/bin/activate
pip install --upgrade kegbot
kegbot upgrade

Then I deleted everything in the kegbot.conf file, replaced it with the following and restarted the server:
(the kegbot.conf file is located at: /etc/supervisor/conf.d/kegbot.conf)

Supervisor.conf for Kegbot – Kegberry edition.

[group:kegbot]
programs=gunicorn,workers

[program:gunicorn]
command=/home/kegbot/kegbot-server.venv/bin/gunicorn pykeg.web.wsgi:application -w 3
directory=/home/kegbot
user=kegbot
autostart=true
autorestart=true
redirect_stderr=true

[program:workers]
command=/home/kegbot/kegbot-server.venv/bin/kegbot run_workers
directory=/home/kegbot
stopasgroup=true
user=kegbot
autostart=true
autorestart=true
redirect_stderr=true


Can't seem to upgrade Kegbot server.. ever
#26

ok i will try to restore before I upgrade, I’ll run it on a test droplet first. Thanks again for the help mikey. sorry i should have read the release notes! My fault.


#27

No worries! Obviously this release could have been a lot smoother, my fault.


#28

I just opened a separate post specifically for the issue but now I’m upgraded I can’t end kegs in 1.2.1, is anyone else having that problem?

UPDATE
I still get a 500 error when clicking the ‘end keg’ button within tap settings on the server however I was able to get the button in the keg room to work without the 502 error by doing the following:

  1. Adding: –timeout=300 to the end of the command line in my kegbot.conf file
    and
  2. Changing the 2 timeout settings in the nginx config file to:
    proxy_connect_timeout 300s;
    proxy_read_timeout 300s;

#29

So i got it to start restoring but it seems to hang (been waiting 15 minutes) how long should it take to restore from a 39mb zip?


#32

Yeah! Upgrade successful! Had some issues trying to get it to run properly on the smallest droplet. Upgrading the droplet one size fixed it. Also had to change the kegbot.conf the way Markarmer did.


#33

I ran the upgrade and am getting the 502 error. Any suggestions, it is totally dead in the water.


#34

Same here, just upgraded to 1.2 and all I am getting is HTTP 500 Internal Server Error which means I’m totally offline now…

Anyone help?

Thanks
Jeff


#35

Doing some more digging it’s like I’m “partially” upgraded. The ‘kegbot version’ is showing 1.2.1 but when I go to the kegbot server I get HTTP 500, however when I type “serverurl/sessions” I can get the page to load, and can get to the stats page and admin pages. I notice on the admin page that I have no ‘keg room’ and it looks exactly like the 1.1.1 version did. Is it possible that my upgrade is just bad? What are my options here? I really do not want to have to rebuild my server and reinstall Kegbot again.

Thanks!!!

Jeff


#36

Fixed it… :smile:
Long story short I had to use the modified kegbot-supervisor.conf file provided above as well as the permission tweaks I talked about in another thread.

Learning new stuff every day…

Jeff


#37

I get this message despite that the file exists and is valid
(kb)[email protected]:/var/log/supervisor$ kegbot run_workers
Could not find local_settings.py; has Kegbot been set up?
Tried: /home/kegbot/.kegbot/local_settings.py

[email protected]:~/.kegbot$ ls
local_settings.py local_settings.pyc
[email protected]:~/.kegbot$

I also get a 504 gateway error when trying to launch kegbot. Anyone have suggestions?


#38

This is exactly the behavior I am experiencing…


#39

See my post above, I think it is number 25 - below the 4 upgrade commands is what I changed my config file to (remove everything existing and replace with what is in my post).

It worked for others on here too after making the change then restarting.

If that works and you get 502 errors see my post below it about ending kegs


#40

I did that, still no dice, I tried even setting the location in the environment, it claims to be looking for the local_settings in the correct place and failing.


#41

Just updated from git master 1.2.1. After pulling and running ‘’‘kegbot upgrade’’’ the system said ‘Version 1.1.1 already installed’. I still ran ‘’’.setup.py/develop’’’. I then made the changes to supervisor configuration file. Trying to start kegbot via supervisor now yields a 502 error.

When trying to run ‘’‘kegbot upgrade’’’ or ‘’‘kegbot regen_stats’’’ I now get an error message from registry.py, line 131, in check_models_ready raise AppRegistryNotReady(“Models aren’t loaded yet.”).

Any ideas?


#42