Kegbot Server v1.2 Released


#43

Upgraded to 1.2.1 from 1.0.1 (I think?) and now I’m getting an OperationalError from Django.

OperationalError at /
(1054, "Unknown column 'core_keg.online' in 'field list'")

(full error here)

I did get a message after running the upgrade command about having to roll back to 1.1.1, then redo the upgrade to 1.2.1. Maybe this caused a problem? Thanks for the help.


#44

For those of you getting errors when trying to run kegbot upgrade when upgrading to 1.2.1, resulting in a 502 error and a run on CPU cycles…

  1. Go into your local_settings.py file and entirely remove the line that begins with CACHES.
  2. Run the following command in the kegbot-server directory rm -f `find . -iname "*.pyc"`. Note the backticks.
  3. Run kegbot upgrade from your virtual environment

#45

Is anyone else getting this error when doing a “pip install --upgrade kegbot” from v1.1.1 to v1.2.1:

Compiling /home/kegbot/kb/build/gunicorn/gunicorn/workers/_gaiohttp.py …
SyntaxError: (‘invalid syntax’, (’/home/kegbot/kb/build/gunicorn/gunicorn/workers/_gaiohttp.py’, 64, 26, ’ yield from self.wsgi.close()\n’))

Afterwards I can get into /kegadmin fine, but anything else throws a 500 error.


#46

It looks like that error message is benign.


#47

Well, I’ve been following the conversation for a while here and I don’t know if the upgrade to 1.2.1 has a solution but I’m still having some problems/errors. Specificially, originally I upgraded from 1.1.1 and when I try to open the app in a browser, I get a “Server Error (500)” but ONLY on certain pages. The Sessions, Stats and Admin pages display OK but the error occurs when I go to the Main KegBot page and the Kegs page (from the main manu) and when I’m in the Admin page. There the Taps, Kegs and Drinks page gets the same error. Of course, my Android App also CANNOT connect to the server and thus CANNOT log new drinks.

Also, I have noticed that when I go to the ‘Sessions’ page, at the bottom it still says that I’m running version 1.0.1 but when I try to upgrade, it comes back with “Installed version 1.2.1 is newer than app version 1.1.1”.

I’m kind of confused where to go from here. I read and tried everything that was said in the above posts and still no go.

Can anyone shed some light on this so I can go back to drinking… peacefully…lol

Thanks for any help in advance… cheers…


#48

So I’ve upgraded from v1.1.1 to 1.2.1, but when I go to upgrade that data I get the following error:
django.db.utils.OperationalError: (1054, “Unknown column ‘core_drinkingsession.timezone’ in ‘field list’”)

Has anyone else encountered this error and know how to get past it?

You can see the full message here: http://pastebin.com/xH77iMm3