New Kegbot Server Install Issue


#1

Old kegbot server is dying, trying to build new one…

For the life of me I can’t figure out how to get the kegbot server (gunicorn and workers) to install to /data/kb/bin/kegbot which is where all of my configuration files from my current install are pointed to. It keeps putting the install at /usr/local/bin/kegbot

I know the silly answer is to just modify my supervisor conf file to point to /usr/local/bin/kegbot but for whatever reason ‘gunicorn’ seems to not like that path and I can’t get past the gateway issue that comes up…

This is what I get for not taking better notes from my first server build as I had all kinds of trouble then but obviously figured it out…

Thanks,
Jeff


#2

What type of OS/Server is your new box?


#3

Ubuntu 18.04.1 LTS

Thanks,
Jeff


#4

I’ve started to look into this and found 2 ways to install Kegbot on an Ubuntu 18.04 box. One is through the Kegberry script that’s designed for the Raspberry Pi, but works very well on an Ubuntu server and automatically sets up the workers/nginx/gunicorn/supervisor etc. There are a couple things you’ll need to tweak with this approach that I can help walk-through but it seems to be the easiest way to get a production-ready setup going.

The other option is to follow the regular Kegbot Server setup and install instructions, which seems to work but requires extra effort with manual setup of nginx/gunicorn/supervisor etc.

If you’re already at the stage of having everything installed and just want to change the directory, I think you can resolve this by fully deleting your existing /kegbot-data and /.kegbot folders and all contents, and then re-running the setup-kegbot.py file. In the prompts that ask you for the location of the .kegbot and kegbot-data folders, you can manually specify /data/kb/bin/kegbot/.kegbot and /data/kb/bin/kegbot/kegbot-data. You may need to run the setup program with sudo (i.e. setup_kegbot.py --allow_root=true) in order to allow the setup program to access these directories.

Let me know if either of these solutions work for you.
John


#5

Figured out what was going on… Fixed it as well… :slight_smile: The process is as follows should I forget again and need to google my own solution… LOL :slight_smile:

  1. Install the dependencies, basically step 1 of the KegBot Server install instructions
  2. sudo pip install virtualenv
  3. sudo mkdir /data
  4. sudo chown <your_linux_username> /data
  5. virtualenv /data/kb
  6. source /data/kb/bin/activate

Fix was found in this thread, reply 1: http://old-forum.kegbot.org/discussions/kegbot-server/127-oserror-errno-13-permission-denied-data

Thanks,
Jeff