New setup - Relay/toggle not working - different arduino needed?

Hey everyone! Last year I started a quest to develop just such a thing…and much to my joy, I found that it already exists! :smile:

I am running Kegberry on a Raspberry PI 2 and have flashed the firmware to an Arduino Uno board that I had in my “projects bin.” I was able to plug 2 flow meters for my 2 taps into the arduino without any issue. The controller is recognized, the flow meters are configured…great!

In my previous work on a similar project, I created a small relay circuit to drive a 12v solenoid. If I plug my “activate” pin for this solenoid into 3.3v or 5v on my Arduino, it fires right up and works great. Try as I may, I cannot get anything to happen though when I have the trigger cable plugged into my A0-A3 relay ports. I did go into my controllers -> Flow toggles in the admin page and have relay0 and relay1 set up there and configured on my Android app correctly for each tap.

From what I’ve been able to find, it looks like this feature isn’t supported on the official kegboard controller, but that it does work properly in a “homegrown” board. I’m wondering though if I by chance might need a specific kind of board to make this work? Or is something else required that I am missing?

Thanks for your help - this is an awesome project!


1 Like

I figured this out. As with the problems with pour authentication that I commented on another thread, this was setup-related on my end. I had to hook the DIY Arduino kegboard into the Nexus 7 with an OTG cable instead of plugging it into the Raspberry Pi. Once I did that the relay started working as expected.


I just recently began my implementation of a relay controlled solenoid (activated via Ibutton authentication) into my Arduino based kegbot. I have everything working as expected, however I notice that I can bypass the Ibutton authentication by simply tapping on the “Tap” screen which brings up the user list and then selecting a user. Doing this opens up the solenoid and starts the pour process as if it had been authenticated. Do you experience the same behavior or are there some settings I haven’t found to prevent this? It kind of makes the authentication process worthless of it can be easily bypassed.



If I remember correctly, you can change this under settings in the app. After that the iButton authentication works the way you want.



You need to go into the app settings and turn OFF on-screen login. That should take care of it.

Yep, that was it, thanks so much to the both of you for your quick response.