Pour ends after 10-20 cl


#1

Hi

I’ve built a kegerator and this is version 2. Something weird has happen with the solonoids, they close after 10-20 cl been poured.
Regulator is on 2 bars
Any ideas?

Got 6 kegs and two taps. threw away my fridge and bought a beer cooler with 3 in and 3 out lines.
Bought a magnetic lock for my fridge, containing beer cans and wine, keeping the neighbors fingers away…

Adding some pictures on my setup

Cheers
Niklas








#2

Bare et kompliment til nabo landet, Kjempe snygt oppsett!! ( Just giving a compliment to my swedish neightbor :slight_smile: )


#3

Your setup looks great.
What kind of solenoids are you using?
How are they wired to the arduino?
Does the android app still think that it is pouring, and what is your timeout set to?


#4

Hi

I’m using:

1/2" Electric Solenoid Valve NSF61 Potable Water 12VDC 24VDC/VAC 110/120VAC G28E

Hooked up to an relay and kbpm


#5

Is the relay staying on throughout the whole pour?
If the relay is staying on the whole pour you may need more pressure (2 bar should be enough according to the datasheet on that solenoid)
What power supply are you using for that solenoid? Have you made sure that the coil voltage is correct? If you were sent a 24V coil solenoid, and you were expecting a 12V coil, you could be under driving it and it may not be enough to open the solenoid all the way.


#6

Hi

The relay is shutting down. I have 2 bar as serving pressure

I’m using a 12 v power supply and I’m sure I got the 12v solenoids.

It used to work flawless but not any more, I have solved it with a bypass switch for opening the valves


#7

Could it be a bad relay on it’s way out? Have you checked to see if the coil still has voltage after it shuts down?


#8

No i haven’t checked the coils
I’ll order a new relay and test


#9

Tried with a new relay but same error persists
Relay0 right tap
Relay1 left tap

When I choose beer connected to relay0 the valves open, but not choosing a beer connected to relay1.
Funny thing is on relay0 it doesn’t take a picture only on relay1

Any suggestions?

Niklas