Problems with latest release on Raspberry Pi 4 and permissions

I’ve been a longtime user of this project for a while now. I remember I had to do quite a bit of “tinkering” to get everythign working in the beginning, and had a lot of help from @johnnyruz (who had the patience of a saint, BTW). My build post can be found here: Keg Cabinet + Kegbot Build - #4 by crankycowboy

In any case, my sd card became corrupt, and I just didn’t use it for a while. I realized I never backed up the SD card once it was functioning (raspberry pi 4). So…back to the beginning and I saw the new server release using docker/docker compose. That seemed easier, so I decided to take a stab. I downloaded the latest raspberry pi image, installed docker and docker compose. But when I try to create the directory for kegbot-data (mkdir /home/user/kegbot-data), I get an error stating that basically says permission denied. I assume that the default “pi” user can’t create a folder in the home directory. So I instead created the directory in /home/pi/user/kegbot-data which worked. I edited the location in the config file, but when get to the point to launch the services and enter: “docker-compose up”, I get an error message something along the lines of: MySQL no matching manifest for linux/arm/v7 in the manifest list (or some variation of that). I’ve tried granting permissions to all users (chmod) to the home folder, but that doesn’t seem to work. Any suggestions? Thanks in advance.

Well I haven’t received a reply yet…but have made some progress. I wasn’t sure if the error I was getting was related to the fact that I installed the 32bit version of rasbian. I re-created my sd card with the 64bit version. I then created the folders and file in the default location in the installation docs using elevated privileges. When I get to the point of starting the services (docker-compose up), I get an error message. I don’t recall the exact message but something about not being able to find a suitable *yml file. I then navidated to the folder where I saved the .yml file (/home/user/kegbot-data) and then ran the command again and it worked. I let it go through the process and now I can get to the setup wizard. I haven’t gone through the wizard yet because I’m worried that the instance won’t auto start since I have to navigate to it? I have restarted and the service didn’t start, I navigated back to it and tried again, and back to the wizard. After I complete the wizard will it autostart, or will I have to do something specific myself? Thanks!

Geez, I guess disregard. I restarted again and now it appears to have started on it’s own. In any case, I’ll go through the setup and see if I can get back in business. Thanks