Should NEXUS 7 2012 be dropped off the supported list?

The kernel required to simultaneously connect and charge doesn’t seem to be available anymore. New builders who see it on the supported list will get one and then find out they can’t use it.

A few folks were looking for a a couple months ago but that thread seemed to have no resolution (see NEXUS 7 2012 - does it need rooting?).

I have a Dell Venue 8 and a NEXUS 7 2012 so I’ve swapped in my Dell as a workaround.

Unless someone can share the Kangaroo kernel I would suggest it be removed to avoid confusion and people wasting time/money.

I would second dropping the Nexus 7 from the supported list. I’m currently trying to build my system with this exact setup and it has been difficult. I have a thread open on XDA forums to try and track down a replacement kernel/ROM but haven’t gotten any hits back so far. If anyone has the Kangaroo kernel that would be excellent. Otherwise I need to take a different approach. Cheers.

Let me check to see if I have a copy of it when I get home. I used it on my 2012 N7, so I’d be surprised if I just got rid of it (I’m the equivalent of a digital hoarder). I am, however, still on 4.4.3, so I suspect that the kernel version that I have will not be compatible with 5.0+.

I’m not worried about the ROM. Its easy to go back to an older version as needed. Its the Kernel I really need. If you could post both the kernel and the known working ROM I think that would be best. TIA.

Looks like I’m running stock 4.4.2 aside from being rooted and running this kernel. Let me know if you’re able to download it. If the link ever goes dead, someone just post here and I’ll make sure to get it back up. I have topic notifications on here.

Unfortunately I don’t have an md5 to post. I apologize for not being quicker on this. Since kegbot has been running well, I haven’t had much reason to visit the forums.


That is awesome. Thank you for your support to the kegbot community by keeping that option open.


I’m running two of those old Nexus 7’s - I guess I just never upgrade them.

Yep, the situation with Nexus 7 really seems to have gone downhill. We will remove it from the list.

Has anyone found a generally-available alternative they are happy with? There have got to be some decent options with full-sized USB by now, but it’s been a while since I’ve looked…

I haven’t had a chance to try the Kernel jragg posted yet but if it works and can continue to be made available then NEXUS 7 remains viable.

Given that it has integrated NFC there’s good reason to keep it. Will report back once I’ve had a chance to verify.

Would you host that kernel so jragg doesn’t need to?

Rooted my NEXUS 7 and installed the Kangaroo image successfully using TWRP. NEXUS 7 is connected to 3 KBPMs through a powered USB hub (Dlink DUB-H7). Tablet is charging and the KBPMs seem to be happy.

I was getting an odd behaviour where the tablet will register a pour right up to having me claim the pour but then it disappears (ie. doesn’t show up in the recent activity list on the tablet or server, which is a 512M Digital Ocean install). Turns out that the problem was the server and a reboot fixed the problem. I think I need to figure out a regular server reboot cycle.

Other things I’ve noticed is that no image will be automatically taken when pouring from two of my KBPMs but it will be taken consistently from the other (which is the 1st tap in my setup), even though “Automatically Take Photos” is checked in the settings.

Images are actually quite bright, even on the tablet despite being in a low light environment.


I was having odd server issues with the same sized droplet. I found that installing swap helped correct it. I did a 4 gig partition but others reported that a 2 gig proves effective.

Guide for swap install on DO:

Also there seems to be a bug with only the first listed tap being the only one to automatically snap a photo. Not sure how much emphasis has been placed on correcting this.

Awesome jragg. Thanks for the kernel. I’m outta town but I will drop this kernel onto the Android device and try it out when I am back. I’ll also go find a good ROM. Cheers.

I found the source for for one of those kernels a while back and ported just the code for USB host mode charging into a patch. I wanted to clean it up and see if I could increase the current, but I never got around to it. Anyway, I finally tried applying it to the 5.0 kernel and it works!

You can find the source and a pre-built kernel at

I verified it’s working with the 2012 Wi-Fi 5.0 factory image from I’m going to try with the 5.1 kernel/ factory image once I get some free time.

1 Like

Adding swap space solved my server problem - thanks joshua. I’m monitoring memory usage now to make sure it’s not leaking.

I’ve got NFC cards working and that avoids the picture taking issue. When you authenticate with an NFC card it snaps a picture immediately.