Trying to change local_settings.py but get permission error


#1

I used the kegberry image to install Kegberry on a Pi, everything seemed to work - server started up I am able to get to the page and everything, but I need to disable debug mode. I tried editing the local_settings.py file under /home/kegberry/.kegbot but I get the error I/O permission denied.

I am guessing it’s because the kegberry services are still running, but I am not sure how to stop them. I tried terminating them (not ideal) and got error there as well.

This is the first time I’ve ever really played with Pi, so probably not the best intro for me. I am not a programmer, but I pick up on things pretty quickly… sorry if these are just completely stupid questions haha.


#2

Ok, never mind :stuck_out_tongue: I logged out as the Pi user, logged in as Root and was able to save my changes. Restarted the Pi and now all is good!


#3

Glad you got it sorted!

Just FYI, kegberry runs everything as the user kegberry. This account doesn’t have a password, but you can become the user (from the pi user) as follows:

(pi) $ sudo su - kegberry