TypeError - I'm stuck

Hey all-

So I have an RPI2 running kegberry, I flashed the kegboard firmware to an Audrino, hooked up 2 flow meters (which I can see in set-up)- everything smooth until I click on the “Admin” tab in the web interface.
I get: TypeError at /kegadmin/taps/1/

Further, it’s not ‘seeing’ pours… I have no idea what to do… :confused:
Please help!
Thank you!!!

-David Z

The issue is within celery. Type in sudo apt-get celery. You may want to update redsis as well same method.

hmmm
I literally have no idea what any of that means, I’m not a programmer. :hushed:

But at least now I can describe the problem to someone who is.
Thanks so much, I really appreciate it!

It’s actually not programming. It’s very simple if you want to do it on your own. If you go to the command line on the raspberry pi and type in the following Sudo apt-get update celery and sudo apt-get update redsis. You should be good to go I ran into same issue and realized that the logs states that there is an issue with celery so once you update it it should be good to go.

Of course no problem if you have any other questions send another message

I too have the same issue and know very little about programming / typing in commands.

I tried "sudo apt-get update celery"
the reply is “E: The update command takes no arguments”

so I tried both apt-get upgrade and apt-get install, both reply with:
“E: Unable to locate package celery”

Any thoughts or suggestions?

Once I get home I will verify that I am giving you the proper command. You are using kegberry? Just making sure

Ok I apologize if I caused any confusion I forgot it was a little more in depth than just the following here is the exact steps you need to take to update celery and redsis.

You first need to ssh into your kegbot or just use the command line on the raspberry pi.

Next you need to switch the user as long as you did the kegberry install by that you will type this command
su kegbot

Next you need to get access to kegbot-server.venv by doing that you will type in the following command.
. kegbot-server.venv/bin/activate
(Make sure that this is exact or else it will not work.) (it should look something like this (kegbot-server.venv) [email protected])

Next these two commands are two update the stats which should fix the issue you are having.
pip install -U celery
pip install -U redis

Once you enter those two commands separately it should state the two where updated. Mostly likely you will need to reboot the Pi after you enter everything in so from the command line enter these last three commands and you should now see everything if not please upload your log information.

exit
exit
sudo reboot now

EDIT:If you have any issues with the commands please take a screen shot or something the best way of doing these really are from ssh though because you can copy and paste.

Sorry for my lack of knowledge here. I am not using an SSH, just going right to the Terminal on the raspberry pi.

Even my first step - switching the user is unsuccessful. When I type in “su kegbot” it prompts me for a password. I’ve tried typing everything I could have possibly set for a password. No matter what I type, the field after “Password:” remains blank. I even tried not typing in a password, just pushing enter. The response is always “su: Authentication failure”.

Sorry again for being so unknowledgable. I really appreciate you taking the time to reply. If you need screen shots of my raspberry pi it looks like I can install scrot.

Quick update. I was typing the commands as is. I tried again this morning with sudo in front of the commands. “sudo su kegbot” seemed successful. But when I try the next command “sudo kegbot-server.venv/bin/activate” it again prompts me for a password - “[sudo] password for kegbot:” Again, I’ve tried everything I could have possibly used for a password, including no password / just pressing enter. No matter what, nothing is typed into the password field and the response is “Sorry, try again” and after 3 incorrect attempts it returns to the command line.

Thanks again for your advice.

After some googling i found this link:

it allowed me to change the user password. I also had to add user kegbot as a sudoer.

It didn’t recognize the kegbot-server.venv command, “sudo: kegbot-server.venv/bin/activate: command not found”

but both the install of celery and redis went ok.

still receiving the same error “socket_connect_timeout”

If you aren’t stepping into your virtual environment before updating those packages, things aren’t going to work.

The command you are using to activate the virtual env is wrong. First, you don’t use sudo for that. Second, it should be prepended with the “source” command or a period (like @dlomm did in his instructions).

Assuming kegbot-server.venv is where the virtual env was created, the command you’d run is:

source kegbot-server.venv/bin/activate

or the shorthand version:

. kegbot-server.venv/bin/activate

When I type in “source kegbot-server.venv/bin/activate” or “. kegbot-server.venv/bin/activate” both commands come back with “bash: kegbot-server.venv/bin/activate: No such file or directory”

Sorry about my lack of knowledge. Any suggestions?

Next you need to get access to kegbot-server.venv by doing that you will type in the following command… kegbot-server.venv/bin/activate(Make sure that this is exact or else it will not work.) (it should look something like this (kegbot-server.venv) [email protected])

I’m confused by this part… should it be typed in as:
. kebot-server.venv/bin/activate
ot should there be something with @yourhostname in there? (not sure what my host name is either)

Thanks for any advice

I was able to find the correct path at:

/home/kegbot/kegbot-server.venv

Glad you where able to figure it out. Im sorry been busy working on my keezer project just about done. Once I finish I may redo the whole process over again with pictures for people who may be having issues with it. Glad you figured it out though. If you have any other questions just repost.

Attached is a newly created guide which I hope helps every person who may not have much technical background. Just follow these images and you should be in the clear until they update there software. If anyone has any other questions just post it here.