Using Multiple KegBoards


#21

Hmmm. Not sure exactly what this all means. How do I go about using this?


#22

I have had this problem in the past, you need to have a serial number set. I made a custom board for an arduino mega so I could run 6 on one board. I had to set the serial number of each board using the support library.

https://kegbot.org/docs/kegboard/support-library/

set-kegboard-serialnumber

It isn’t in the kegbot server checkout, it is in the kegboard checkout.


Any help or advice for android setup
#23

SUCCESS! In virtual env I installed kegbot-kegboard. Then I was able to use set-kegboard-serialnumber command. Wrote down serial numbers. Erased all my controllers. Added new controllers and flow meters with serial numbers. Tested each one separately and it recognized them as different kegboards. Plugged them both into a USB hub, and everything still worked perfectly. Going to finish hooking everything up this weekend and I’ll be testing it with beer instead of test pin 12. Thanks for all the help guys! Build finish photos to come when everything is cleaned up!


#24

Hey guys,
I’m pretty sure I have this exact issue.

Background - I had a mega supporting 3 taps, tablet/android interface and ubuntu (running in virtualbox) server. Worked flawlessly.

I recently built a new keezer with 8 taps.
I have a second arduino mega. Both plugged into the tablet and it will only recognise pours from one (looks like which ever one was ‘reconsied’ first. Testing seperately they both work as expected). I imagine becasue it recognises both as being named ‘kegboard’.
I have tried (and failed) like @scottieb5 to rename one to kegboard2. Still calls both kegboard.

I’m hoping set-kegboard-serialnumber will solve my issue.

I’m following the instructions posted by @thehijjt above - https://kegbot.org/docs/kegboard/support-library/

Created the virtual environment, activated it, but get an error when trying to install kegboard

See below. Any ideas?

(kegboard) [email protected]:~$ pip install kegbot-kegboard
Collecting kegbot-kegboard
Using cached https://files.pythonhosted.org/packages/16/8c/8719474c073a453eb2c74cd9338e62d464cd998d50deedb4abcc8af48c96/kegbot-kegboard-1.1.5.tar.gz
Complete output from command python setup.py egg_info:
Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.12.tar.gz
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-bZhLcj/kegbot-kegboard/setup.py”, line 48, in
setup_package()
File “/tmp/pip-install-bZhLcj/kegbot-kegboard/setup.py”, line 19, in setup_package
use_setuptools()
File “distribute_setup.py”, line 145, in use_setuptools
return _do_download(version, download_base, to_dir, download_delay)
File “distribute_setup.py”, line 124, in _do_download
to_dir, download_delay)
File “distribute_setup.py”, line 193, in download_setuptools
src = urlopen(url)
File “/usr/lib/python2.7/urllib2.py”, line 154, in urlopen
return opener.open(url, data, timeout)
File “/usr/lib/python2.7/urllib2.py”, line 435, in open
response = meth(req, response)
File “/usr/lib/python2.7/urllib2.py”, line 548, in http_response
’http’, request, response, code, msg, hdrs)
File “/usr/lib/python2.7/urllib2.py”, line 473, in error
return self._call_chain(*args)
File “/usr/lib/python2.7/urllib2.py”, line 407, in _call_chain
result = func(*args)
File “/usr/lib/python2.7/urllib2.py”, line 556, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 403: SSL is required

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-install-bZhLcj/kegbot-kegboard/


#25

Yeah, that SSL issue is the main problem I had to solve when I initially setup my Kegberry installation. All of the Python repositories have been updated to require SSL while the links to the repositories from the legacy packages in Kegbot still point to the regular HTTP links.

If you download my package from the link in my “Kegbot/Kegberry New Installation” thread, it contains the raw package files in the zip file. Open the install_part2.sh file and you’ll see the commands required to manually install the packages in the correct order. You may have to tweak them a little bit to point to the correct directories where you’ve saved the tar.gz package files, but they should all install successfully and you’ll be able to run the “set serial” command.


#26

Thanks (AGAIN) @johnnyruz !
Will give it a shot


#27

Success!
Thanks again @johnnyruz
Buy that man a beer…