Android App news: Open beta launched & beta 85 released!


#1

Hello everyone! It’s been (gasp) over 2 years since the Android app had some love. Wow! Well here’s some news:

New Open Beta Program

Google play now supports “open enrollment”, for anyone wanting early access to new app versions. I’m trying it out with this release, and will generally stage versions there for a few days or weeks first, depending on complexity.

Instructions: Go to https://play.google.com/apps/testing/org.kegbot.app and enroll!

v1.0.0b85 — Released to beta channel 9/16/2016

New in this version:

  • Wifi kegboard support (alpha): Supports the brand new, experimental wifi kegboard device. Yes, this means you can run a Kegbot on a modern tablet, no USB required!
    • Go to settings -> kegerator to add a “network controller”.
  • USB support bugfixes: Some under-the-hood updates to the USB support library. There should be bugfixes… and maybe new bugs!

If you give this version a try, whether or not you’re using the wifi support, I’d love feedback on whether things still work. It’s been a while since I touched the code… I’m rusty!

cheers,
mike


#2

#3

Hi Mike,

I received my Particle Photon, flashed it, attached a flow meter and can see the output via telnet. So that part is all good and was relatively easy.

I updated my Android Kegbot to the beta 85 version, but I do not have an option to add a network controller in the settings -> kegerator panel. :frowning:

Is it possible that the Android app requires a physical controller (Arduino) to be plugged in to enable the controller option?

Any suggestions on how to proceed? (Attaching an Arduino is possible, just less convenient.)

Thanks


#4

Thanks for the report back! Hmmm… I think the most likely explanation is I messed up the release somehow, as there aren’t any other requirements that would keep you from seeing the option.

I’ll take a look at this tonight or this weekend at the latest - thanks!


#5

Also not seeing it here under settings/kegerator or anywhere else. Confirmed I’m running Beta 85 build. My tablet is plugged into my kegbot

Or on my other tablet that is not hooked to my Kegbot. Figured I’d check both.

I plan on getting a proton in the future so looking forward to seeing this work.


#6

Also, is the beta source on Github?

I had a few minutes and I was going to poke around, but no recent updates to kegbot-android (which is where I assumed this would be).


#7

Sure enough, I had cut the release a bit too hastily. Beta 86 has been posted to the beta channel, and the android sources have been updated as well. Enjoy!


#8

Beta 86 is better, but no real joy yet.

I only had a few minutes to try it. I was allowed to add the controller and it picked up the serial number from the Photon. But when assigning the flow meter to a tap, it only offered “flowN” rather than “meterN”. The app would not recognize any pours though I could see via the serial port that they are being sent.

I tried updating the Photon code to send “meterN.ticks=#”, but that doesn’t work any differently.

Also the app did stop a few times, but that may be the tablet I’m using (Samsung Galaxy Tab3).

Gotta run now. I’ll dig deeper later.


#9

Actually there is joy.

I forgot that I tacked a timestamp onto the end of the message so I could see when the ticks were reported. I expected the parser would ignore the extra crap at the end, but no.

When I restored the firmware to use “meter” and deleted my timestamp, pours are now captured correctly.

Woohoo!


#10

Hi Mike,

Are you sure you updated all the Android sources on Github?

I can’t find the actual code that connects with Photon and handles the “merterN.ticks” messages.

Also, there are no b85 or b86 tagged files for the two latest betas.

Thanks


#11

Yes, the code is in github: https://github.com/Kegbot/kegbot-android/commit/b70b5a7092a9bafec19137186c2b8fb5334cd058


#12

FYI, I have experienced a few times when the Android app stops recording pours after running for hours or days.

Restarting just the app does not seem to reconnect to the meter. Restarting the Android does seem to get things working again.

I’m not sure if there is anywhere to look for more details on what is happening.


#13

Are you using the network controller or an android one?


#14

Hi thehijjt,

I am still in proof-of-concept mode, so I don’t have a true production configuration.

I am most interested in the Particle Photon network controller and that is what I am testing with now, but I do have a couple of Arduinos around that I was previously experimenting with.

My comment above was feedback for Mikey that my Android tablet seems to lose connection to the Photon network controller and rebooting the Android appears to reconnect things. Restarting the Kegbot app without restarting the Android does not seem sufficient in my limited tests.

Thanks!


#15

I don’t have a proton, but I do have a bunch of wemos 8266s laying around that I could give a try. The way the android app works isn’t exactly what I would want to do if I was using WiFi. I would want multiple devices that handle one flow meter, one RFID reader, and one relay each. The devices would sleep until they get RFID or flow.

To debug your problem you need to see if it is a problem in the android or in the proton. Make sure that when you restart you are force closing the app all the way. Go to settings apps and kegbot, and force close it. Then reopen and see if it reconnects.


#16

Just got mine up and running. i have to tip my hat to you mr Mike. It works as of now flawlessly on my Shield, i have not tried it on my Samsung yet. but will stress test the Photon tonight i guess( Saturday and the kegs are full) Anyway! Thanks again for this fantastic code!!


#17

I’ve just connected up my photon and running beta 87 on my tablet and it is happily logging ticks to the particle cloud. The kegboard settings option is ‘kegboard hostname’ only, there is no option to add network controller. If i input the photon name nothing changes and I can’t add taps?

I should mention that I’ve had a 4 tap kegbot setup for around 2 years and have had a few issues with kegberry and virtual machines. I’m super green when it comes to coding and developing but hoping to help with any beta testing or debugging.

Cheers


#18

Bumping my previous reply as its been a couple of weeks, hoping this hasn’t lost momentum?

Cheers


#19

Sorry for the confusion: You’ll want to input the local IP address of the photon in order for the app to work. (While the firmware also reports to the cloud, there’s not currently support for using that in the app.)


#20

Excellent, thanks Mike. I’ll give it a try tonight and report back.

Cheers