HowTo: Install Kegbot Server on Digital Ocean

Says not connected…

do you have a different usb cable you could try?

1 Like

I did with no improvement :frowning:

I just want to say thank you to Joshua White for all his assistance.

Can someone here tell me if company support is offered with this product? I sent an email to the company about the kit being out of stock with no reply. When I didn’t hear back, I created a thread and Mikey posted in it. He said he would post back in that thread and on Twitter once the items are in stock. I have since ordered and received my kit but no post in that thread, no Twitter update.

Once I got my kit up and running, I found an issue and began posting in this thread. I also sent a PM to Mikey about it.

No reply.

I received my Kegbot 5 days ago and it still does not work due to the app not recognizing that the flow sensor is connected (light of KegBoard does flash). The wife isn’t into this and can’t understand why I would spend this kind of money with a company that can’t reply.

My question is: is there any way to have someone at Kegbot troubleshoot this or am I on my own? If not, I have a Kegbot to return, a mounting system, and a Nexus 7.

Sorry if I sound pissy but I’ve run many companies from one man band $25-50k in sales/year to $3M to 10M in sales and I always got back to my customers.

Thanks!

Sean

Do you remember which kernal you installed when you rooted you nexus 7?

1 Like

It wasn’t I - I bought it already rooted and upgraded to 5.1:

3.1.10-gf5d7b8b

Build LMY47D

While I was checking the build number, I noticed that the N7 wasn’t charging. When I swapped the cables around so the original charger/cable was connected, it charged just fine.

I suppose the OTG cable could be bad (even though the kegboard is getting a flow sensor signal when pouring).

Thoughts?

Thank you very much for sticking with me on this.

could be a bad otg, could also be the rooted kernel is conflicting with lollipop, could be that the person who rooted your device didn’t turn on otg charging. you could try booting into recovery mode and making sure that its on.

honestly I think the issue is lollipop. I would reflash the device back to kit kat and root it following the steps here

1 Like

I know I ran into some problems when I installed my setup where either the Nexus would not show charging or the controller would not show attached depending on the order in which the USB OTG/kegboard pro mini/Nexus 7 were connected. Same as you, I would get lights on the KBPM but the ‘no controller attached’ message. It’s been awhile so I can’t remember the order I took to finally get it to work, but I would start by trying to reconnect the USB OTG/KBPM/Nexus in different order and see if that brings you any luck. It frustrated the sh*t out of me at the time until I figured that out.

1 Like

I’ll check if OTG is disabled and go back to Kitkat if needed. I’ll report back.

I tried a number of permutations without success. I appreciate the post though!

Unfortunately I have not been able to do this. I’m not familiar with what the PO has on this so it taking me time to figure out. I got into the section the mentions OTG however I am unable to change any of the settings.

The annoying part is my keg blew and is due for replacement today. I’m picking up the new one so it will be a month before I can start with a new keg.

You could always open the keg and fill with water so you are not wasting beer while trouble shooting.

Here is a video on how to pull the spear out so you can fill it and the replace the spear

I was also think maybe you could see if some one has a differt tablet (like an Acer Iconia A210 or a ViewSonic VSD241) that would let you install the app and try it. If it works on the new table you know it is the nexus.

I don’t know anyone with those tablets so I went to check the KB for tablets that are known to work but the page doesn’t exist.

So I tried my Galaxy Tab 3 and I got an identical result.

It is probably the software the N7 is running. I tried flashing it with the build found on this forum but I’m still having trouble. The previous owner that loaded the software was slated to help me this week was hit by a car (no kidding), broke his collar bone and some other bits so he is out of commission for a couple months.

If anyone here is familiar with TWRP, shoot me a PM.

Samsung’s do not work with kegbot, they lack support of USB host mode. In therory any tablet that supports usb host mode should work. Ones with a dedicated power supply seem to work with less hassle. The page you are looking for that covers verified tablets is

The following was also posted to Mikey’s support thread…

Update:

I finally found another Nexus 7 to borrow and it works! I ran through the same procedure on both (wipe back to stock, starting over, then moving forward with the kangaroo zip) and the borrowed one works great while mine doesn’t. No idea what the issue is but I’m going to keep at it.

Thanks to Josh and Mikey

I see above I need to edit the local_settings.py file however as all I have is a command line, I don’t know the command to download (and then re-upload) the file.

I’m not familiar with what the PO has on this so it taking me time to figure out. I got into the section the mentions OTG however I am unable to change any of the settings.. .

I’m curious about the “Size” of the droplet needed to run the server. I’ve had a server set up on a Raspberry and it its terribly slow at the 512 RAM.